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1. Safety precautions and measurement conditions 

• Prior to mounting the profilometer onto the rail, areas of contact and laser 
scanning of the rail surface should be thoroughly cleaned from dirt. 

• When mounting the module on the rail, do not allow heavy shocks of its 
support against the rail. 

• The output windows of the laser sensor must be carefully inspected and 
cleaned. 

• Do not use laser module in locations close to powerful light sources. 

2. CE сompliance 

The profilometer has been developed for use in industry and meets the 
requirements of the following Directives: 

• EU directive 2014/30/EU. Electromagnetic compatibility (EMC). 

• EU directive 2011/65/EU, "RoHS" category 9. 

3. Laser safety 

The profilometer makes use of a c.w. 660 nm wavelength semiconductor laser. 
Maximum output power is 1 mW. The device belongs to the 2 laser safety class. The 
following warning label is placed on the profilometer body: 

 

The following safety measures should be taken while operating the profilometer: 

• Do not target laser beam to humans. 

• Do not disassemble the sensor. 

• Avoid staring into the laser beam. 

4. General information 

Portable Rail Profilometer (PRP) is designed for non-contact registration of the 
cross-section of the railhead acting face. 

The main functions of PRP are as follows: 

• Obtaining information on the cross-section profile of the railhead acting face. 

• Full profile scanning and analysis of the railhead acting face. 

• Visualization of combined graphic images of the actual and new cross-section 
profiles of the railhead. 

4.1. Controlled parameters 

• Railhead vertical wear (Hv). 

• Side wear (Hh), that is measured 13 mm lower the top of railhead and side 
wear (HhR45), that is measured at 45 degrees relative to the rail symmetry axes 

at the point that passes through the center of lateral working fillet. 

• Reduced head wear, that is determined as vertical one + the half of lateral 
wear, namely: Hr = Hv + 0,5Hh or Hr = Hv + 0,5Hh   . 
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5. Basic technical data 
 

Parameter Value 

Railhead vertical wear, mm from -15.0 to +20.0 

Lateral railhead wear, mm from -15.0 to +20.0 

Redused railhead wear, mm up to 20.0 

Scanning angle inside the rail track, degrees 108 

Scanning angle outside the rail track, degrees 108 

Measurement error, not more than, mm ±0.1 

Scanning time, sec 10-12 

Laser module dimensions, mm Fig. 3 

Power supply, laser module 
3.7V 

Li-ion battery, 6800mАh 

Power supply, PDA 
3.7V 

Li-polymer battery, 3300mАh 

Number of measurements that can be taken before battery 
recharge, not less than 

500 

PDA memory capacity 100 000 measurements 

Interface between a laser module and PDA Bluetooth 

6. Complete set to be supplied 
 

Designation Name Quantity Weight, 
kg 

RF303 PDA 1 0.4 

RF570 Laser scanning module 1 4.0 

RF570.40 Charging device 5V 1.0A for PDA and laser module 2 0.2 

RF570.42 Universal cable (USB-port) 1  

RF570.43 Bluetooth-adapter 1  

RF570.30 Packing case 1 1.5 

PRP_DB Database management system (CD) 1  

RF570UM User's manual 1  

 Calibration tools (optional):   

RF570.20.100 Calibration unit  3 

RF570Calibr Software   

* The profilometer may be supplied without a PDA. In this case, to operate the 
gauge, an Android-based device (smartphone or tablet) with licensed software (paid 
license) is required. The software can be downloaded from the website: 

https://riftek.com/upload/medialibrary/d15/rnhed80h13jb9ndrvl9n3ycnyar96wc6/p 
rp.zip 

The software for maintaining the electronic database of rail wear is available on 
the website for free download: 

https://riftek.com/upload/medialibrary/e3d/dif6fhqwej3kzdhmlltw71tn8bwkdkex/In 
stall_Prp_db_6.15.3.1_b182.zip 

The laser profilometer is supplied in a special protective case that prevents the 
device from being damaged during transportation. 
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6.1. PDA software licensing 

By default, the PDA is configured to operate with the PRP device it was supplied 
with. One software license allows the PDA to connect to a single PRP device. 

A single PDA can support an unlimited number of licenses for operation with an 
unlimited number of devices. 

A single license can be installed on an unlimited number of PDAs. 

7. Structure and operating principle 

7.1. Basic components of the device and their functions 

Figure 1 shows basic components of the device. 
 

Figure 1 

(1) Display device (personal digital assistant, PDA). 
(2) Laser scanning module 
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7.1.1. Laser scanning module 

The module is intended for laser scanning of rail surface. 
 

Figure 2 

(1) ON/OFF button 
(2) Indicator of Bluetooth connection (blue LED) 
(3) Indicator of turn ON (red LED) 
(4) Support for mounting of the device on the rail 
(5-6) Clamps for mounting of the device on the rail head 
(7) Input window of laser sensor 
(8) Output window of laser sensor 
Overall dimensions of scanning module are shown in Figure 3. 

 

Figure 3 

7.1.2. Display device (PDA) 

The display device (PDA) is designed to control the laser scanning module, 
receive data from the scanning module, display measurement results, input parameters, 
and store data. 
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Figure 4 

Figure 4 shows the following: 
1 – Power button. 
2 – Charging port. 

8. Operating principle 

The operator mounts the laser scanning module onto the railhead to be 
measured. Upon command from the PDA or PC, the laser module performs a non- 
contact scan of the rail surface. The measurement results (geometrical parameters and 
surface profile) are displayed on the PDA screen, can be saved in the PDA memory, 
and transferred to the PC database. Additional parameters are also saved, including the 
measurement date, operator code, track distance, track number, rail type, etc. 

 

9. Rail parameters under control 

9.1. L-parameters 

Geometric parameters of the rail are calculated automatically after laser 
scanning of the rail is completed. To calculate geometric parameters, use is made of 
reference points on the railhead. Location of the reference points is shown in Figure 5 
and is defined by L-parameters. Values of L-parameters preset in PDA are given in 
Table 1 and can be changed by user. 

 

Figure 5 
Table 1. 

 

L-parameter Default value Description 

L1 13 mm Used for calculation of lateral railhead wear. 

L2 20 mm Used for calculation of railhead width. 
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9.2. Geometric parameters of the rail under control 

The parameters under control and respective calculation methods are given in 
Table 2. 

Table 2. 
 

Parameter Designation Calculation method 

Railhead vertical 
wear 

Hv is calculated as a difference between the measured value and 
nominal value of new rail in direction of rail axis of symmetry 

Lateral railhead wear Hh is measured at the height of L1 = 13 mm from the rolling surface of 
rail head 

Lateral railhead wear 
at the angle of 45 
degrees 

Hh45 is measured at 45 degrees relative to the rail symmetry axis at the 
point that passes through the center of lateral working fillet 

Reduced railhead 
wear 

Hr is determined as vertical one + the half of lateral wear, namely: Hr = 
Hv + 0,5Hh. 

Reduced railhead 
wear at 45 degrees 

Hr45 is determined as vertical one + the half of lateral wear at 45 
degrees, namely: Hr45 = Hv + 0,5Hh45 

Railhead width W is measured at the height of L2 from the rolling surface of rail head 

10. Application installation 

If the PRP was supplied without a PDA, to install the application, run the file 
prp.apk and grant all required permissions. 

 

If the permissions are denied, the device will not function properly, and a warning 
message will be displayed. 

11. Adding and selecting a measuring device 

By default, the PDA is configured to operate with the PRP device it was supplied 
with. To add a new device, follow the instructions provided below. 

Go to the Tools menu by either tapping the menu icon  or swiping from the 
left edge of the device toward the center of the screen. 
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Here you can enable or disable Bluetooth, select the type of measuring device 
(default is IKP), and add a new measuring device depending on the selected type. 

To add a device, turn it on and tap the SCAN FOR DEVICES button. 
If the search is successful, the device will be added to the AVAILABLE 

DEVICES list. To pair, tap on the detected device. 
 

The device will be paired but locked for selection as the primary device for 
synchronization ( ). To unlock it and set it as the primary, swipe the entry from right to 
left and tap the SELECT button. 
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In the pop-up window, you must enter the key or scan the QR code. The unique 
key or QR code is provided with the measuring device or upon request. If the key is 
incorrect, an error message will appear. 

 

To scan the QR code, you must allow the application to take photos and videos. 

12 



Portable Rail Profilometer. PRP Series 

PRP [Revision 2.0.0] 15.03.2018 

 

 

 

 

If the correct key is entered, the lock icon will disappear, and a check mark ( ) 
will appear on the selected device. 

 

The selected device will connect automatically when the application starts. Later, 
if the desired device is listed (and unlocked), it can simply be selected. 
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If the measuring device will no longer be used, it can be removed from the list of 
available devices by unpairing it. To do this, swipe the entry from right to left and tap the 
Delete button. 
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12. Setting up PDA software 

Before starting work with the device, the software must be configured. To do this, 
select the General settings item in the menu: 

 

12.1. General settings 

Selecting the General item opens a window for setting up the password and 
Bluetooth connection: 
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12.1.1. Password 

The Password settings item allows you to set a password to access all basic 
settings. 

 

To set a password, you need to select the Password item, enter the password 
and confirm the entry. The default password is "1111". 
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12.1.2. Bluetooth 

The Bluetooth settings section allows you to configure the Bluetooth activation 
mode and the connection behavior of the selected measuring device when the 
application starts. 

 

Autoconnection – if this option is enabled, the application will attempt to 
connect to the measuring device selected in the settings upon startup (see Adding and 
selecting a measuring device). 

If this option is disabled, to establish a connection with the device, you must tap 
the synchronization icon in the main window of the application. 

Turn on confirmation – this option becomes available only if the 
Autoconnection option is selected. When enabled, the application will prompt for 
confirmation to enable Bluetooth at startup. 

12.1.3. Language 

Changing the application language is performed upon request to the 
manufacturer (info@riftek.com) and is a free service. 

mailto:info@riftek.com
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12.2. General measurement parameters 

Selecting the Measurement item opens a window for configuring the 
measurement parameters. 

 

Units – you can choose mm or inches. 
Show chart – this option allows the measured rail profile image to be displayed. 
Align measured profile – automatic alignment of the measured profile with the 

selected reference profile. If the option is not selected, no alignment is performed after 
the measurement. The profile’s tilt angle and its displacement along the X and Y axes 
are calculated based on the device calibration. 

12.3. Data export 

Selecting the Data export settings item opens a window to configure options for 
exporting saved data: 
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12.3.1. Export to PDA 

To enable data file saving on the smartphone, check the Save to smartphone 
option. 

 

Next, select the desired file format (CSV, XLS, XML). 
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12.3.2. Export to PC database 

To enable data export, select the PRP_DB database option. 
 

To enable data transfer between the mobile device and the PC, the PC's IP 
address must be configured. Data exchange is carried out via Wi-Fi. The PC and the 
mobile device must be connected to the same Wi-Fi network. This can be either a 
dedicated network created on the Android device (a virtual hotspot) or any home/office 
network. 

12.3.2.1. PC server settings 

To transfer data to the PC, you must specify the IP address of the server running 
in Prp_DB. Download link for the Prp_DB application: 

https://riftek.com/upload/medialibrary/e3d/dif6fhqwej3kzdhmlltw71tn8bwkdkex/In 
stall_Prp_db_6.15.3.1_b182.zip 
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The IP address can be determined on the PC. There are two ways to find your 
IP address in Windows. 

Method 1. Find the IP address using the Settings app (Windows 10). 
1. Select Start > Settings. 

 

2. Select Network & Internet. 
 

3. In the left panel, select Wi-Fi. 
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4. Click on your network or connection name. 
5. Scroll down to the IPv4 address – this is your IP address. 

 

Method 2. Find the IP address using the command line. 
1. Click Start, type cmd in the search bar and press Enter. 

 

2. Type ipconfig and press Enter. 
 

3. Find the IPv4 address – this is your IP address. 
 

 

 

 
PC. 

This IP address must be specified in the PC server settings. 
The port number is the same as in the settings of the Prp_DB program on the 
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12.3.2.2. PDA server settings 

The server on the PDA is needed to transfer reference files and processing 
scheme files from the Prp_DB program. 

The IP address field is unavailable for editing, it displays the IP address of the 
PDA in the Wi-Fi network. This IP address is used in the settings of the Prp_DB 
program (see Synchronization of PDA and PC). 
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12.3.3. Sending data via email 

To enable the option to send data files via email, check the Send email option. 
 

To send data, you need to enter the recipient's email address and select the file 
format (CSV, XLS, XML). 
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12.4. PRP measurement parameters 

The Measurement parameters settings menu item is responsible for 
configuring the calculation of the controlled parameters of the rail head. 

 

Calculation methods – configure the methods used to calculate rail head 
parameters. 

Calculated parameters – select the rail head parameters to be calculated and 
displayed. 

L parameters – set the reference point values for calculating rail parameters. 

12.4.1. Calculation methods 

Select the Calculation methods item: 
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Lateral wear from: 

Reference profile 

Wear is measured at a height of L1 from the running surface of the reference rail head. 

Measured profile 

Wear is measured at a height of L1 from the running surface of the measured rail head. 

 

Lateral wear: 

Inner 

Lateral wear is measured on the inner side of the rail. 

Outer 

Lateral wear is measured on the outer side of the rail. 

Inner&Outer 

Lateral wear is measured on both the inner and outer sides of the rail. The maximum wear value will be 
displayed. 

12.4.2. Calculated parameters 

Select the Calculated parameters item: 
 

To select or deselect a parameter, tap the desired item. 
For parameter descriptions, see par. 9.2. 

26 



Portable Rail Profilometer. PRP Series 

PRP [Revision 2.0.0] 15.03.2018 

 

 

27 

 
12.4.3. L parameters 

Select the L parameters item: 
 

For parameter descriptions, see par. 9.1. 
To edit a parameter, tap on the parameter and enter a new value in the window 

that appears. After entering, tap ОК. 
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13. Setting reference profiles and tolerances 

Swipe right from the left edge and select Advanced settings. 
 

Reference – selection of reference profile. 
Tolerance – tolerance settings for the measured parameters. 

13.1. Reference profile 

The application allows the scanned rail profile to be compared with the reference 
profile. 

13.1.1. Selecting and deleting the reference profile 

To select a reference as the main one, you need to swipe left from the right edge 
and tap Select. The selected reference will be marked with . 
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To clone a reference profile, tap Clone and enter a new profile name. 
To rename a reference profile, tap Rename and enter the new profile name. 
To delete a reference profile, tap Delete. 
To delete multiple or all reference profiles, perform a long press on the Delete 

button to activate multi-selection mode. 
 

The menu includes the following buttons: 

– Delete selected references. 

– Select all references. 
To view the profile and parameters of the reference, tap on the desired item. 
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13.1.2. Uploading the reference profile to the database 

The app comes with several pre-installed reference profiles. 
If the required reference profile is not in the database, the user can request 

RIFTEK (free service) and then add the profile. 
There are three ways to add a new reference to the database: 

1. Copy the reference file to the device (in any standard way) and tap . Select 
the files you need and tap Select. 

 

2. Export a profile from the database of measured profiles. 
3. Export the reference file from the Prp_DB program. 

13.2. Tolerances 

The application automatically monitors whether the measured geometrical 
parameters exceed the specified tolerances. 

13.2.1. Viewing and deleting tolerances 

For tolerances, the selection of the main tolerance is not used, since tolerances 
are linked to reference profiles. For each reference profile, a tolerance for the calculated 
parameters of the rail head can be added. 

In the example below, tolerances have been added for the "54E1" reference 
profile. When selecting "54E1" as the reference profile, the tolerance will be used with 
the name "54E1". 

To view or edit the values, you need to tap on the name of the tolerance. 
The table displays the tolerances only for the selected geometric parameters of 

the rail head. 
The maximum/minimum critical values of the parameters are displayed in red. 

The maximum/minimum values of the parameters, which are close to the critical values, 
are displayed in orange. 
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To delete a tolerance, you need to swipe left from the right edge and tap Delete, 
or tap and hold the item with the tolerance name (the procedure is the same as for the 
references - see par. Selecting and deleting the reference profile). 

13.2.2. Adding tolerances 

To add a tolerance, tap  and select a reference for which the tolerance will be 
set. 

 

After adding a tolerance, you must enter the boundary values for the calculated 
rail parameters. To do this, click on the tolerance name and go to the mode for adding 
controlled parameters. Initially, the list is empty. To add a controlled parameter, you 
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must tap  and select the parameter for which tolerances will be entered from the drop- 
down list. The drop-down list contains only those parameters that have been selected 
for calculation (see Calculated parameters). 

 

After selecting a parameter, the limit values must be entered. 
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the list. 

To edit a tolerance, tap the input field and select the desired value. 

To save, tap . The added tolerances for the selected parameter will appear in 
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14. PDA software update 

The software version is shown in the About window. To open the About window, 

tap  or swipe right from the left edge and select About. 
 

To check if you have the latest version, tap the CHECK UPDATE button. If you 
have the latest version installed, the app will display a corresponding message. 

 

If you do not have the latest version installed, you will be prompted to update the 
application. Tap OK to update. The new version of the application will be downloaded 
and installed automatically. 
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rp.zip 

The latest version of the software can also be downloaded from the website: 
https://riftek.com/upload/medialibrary/d15/rnhed80h13jb9ndrvl9n3ycnyar96wc6/p 

The update procedure is similar to installing the application. 

15. Measurement procedure 

15.1. Turning on the profilometer 

• Before first use, charge the batteries of both the laser module and the PDA by 
connecting them to the charger. 

• Turn on the laser module by pressing and holding the power button for a few 
seconds. When powered on, the red LED indicator on the laser module will 
flash. 

• After the laser module is turned on, it will automatically establish a wireless 
connection with the PDA. During this process, the blue LED on the module will 
be lit. Once the connection is established, the LED will turn off. 

• The main application window will be updated: 
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Attention! 
When mounting the module onto the rail, avoid strong impacts of its supports against the rail, as 
this may cause the profilometer to malfunction. 

You need to inspect periodically the output window and basic supports of the laser scanning 
module and to clean them of dirt. 
Do not clean the glass by using abrasive and aggressive cleaning agents. 

To reduce the scanning time, you can manually move the carriage to the start position. 

 

  

The Measurement button, as well as the Bluetooth connection and battery 
charge indicators, become active. 

15.2. Mounting onto the rail 
 

 

To perform the measurement: 

• Secure the laser module onto the rail using the clamps. 
 

15.3. Quick setup 

The main window contains tools that allow the user to quickly configure the 
reference. 

• To quickly select the reference, tap on the current reference (  ) and make a 
selection. 
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To reduce the scanning time, you can manually move the carriage to the start position. 

 

 

 

15.4. Measurement 
 

• Tap the Measurement button on the PDA screen. The application will request 
the calibration parameters of the laser module, and if the parameters are 
successfully read, the measurement window will appear. 
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• When you tap the Measurement button, the laser module will scan the rail 
head surface. The scanning time is 10-12 seconds, during which the red LED 
lights up. 

• After the scanning is complete, the PDA will show the values of the measured 
parameters selected for display: 

 

If the tolerance for the selected reference is specified in the settings, the 
parameter value will be marked with a green icon. If the parameter exceeds the 
specified tolerance, the value will be marked with a red (orange) indicator: 

 

• When you tap the Measurement button, the laser module will re-scan the rail 
head surface (if required). 
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The application allows the user to display only the parameters of the measured 

profile and remove the graphical representation of the profile. To do this, uncheck the 
Reference profile and Show chart, respectively. 

 

• If a calibration block or reference rail was scanned for verification, the scan 
results must not differ from the nominal values by more than 0.1 mm. In this 
case, the device is ready for operation. Otherwise, it must be calibrated 
according to the instructions. 

15.4.1. Saving the measured profile 

• To save the measured profile, tap the Save button ( ) and enter the rail 
identification parameters. 
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The measurement will be saved to the database (see Viewing measurement 

results). 
If a measurement with the entered parameters already exists in the database, a 

warning message will be displayed: 
 

The new measurement can either overwrite the existing one or be canceled. 

16. Browsing the database 

To view the saved data, go to the main menu (tap , or swipe right from the left 
edge of the screen) and select Measurement Data. 

 

A list of saved rail measurements will be displayed on the screen. 
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16.1. Data export 

To export multiple or all measurements, perform a long press on the desired 
entry to activate multi-selection mode. You can optionally filter the required data 
beforehand (see Data filtering). 

 

Next, select the data to be exported to the PC and tap the Export data button ( 

). 
If multiple export options are selected in the export settings, a menu with export 

format options will appear on the screen. 
 

• To export to the PC, select Export to Prp_DB. 
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Attention! 
For successful data transmission, the smartphone must be connected to the internet via a 
wireless network. 

 

 

If the data is successfully transferred, a pop-up confirmation message will 
appear on the screen. 

In case of failure, an error message will be displayed: 

 

• To save data to the smartphone, select Save to smartphone. 
The data will be saved to the internal memory in the \\Download folder. 

• To send data by email, select Send email. 
The data will be sent to the email address specified in the settings. 

 

Attention! 
For successful data export: 

The smartphone must be connected to a Wi-Fi network. 
The Prp_DB application must be running on the PC. 
The correct IP address must be set in the PC server settings (see PC server settings). 
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16.2. Data deletion 

To delete a locomotive/car, swipe left from the right edge and tap Delete. 
 

To delete multiple or all entries, perform a long press on an entry to activate 
multi-selection mode. 

 

Next, select the data to be deleted and tap the Delete item(s) button ( ). 
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16.3. Data filtering 

To add a filter, tap the Filter button ( ), and then select the fields by which the 
data will be filtered. Filtering can be performed by date, station, and line number. 

 

Example of filtering by the Date parameter: 
 

Next, tap the date selection icon ( ) and choose the desired date. 
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To apply the filter, tap . The list will display only the measurements that match 
the filter criteria. 

 

You can also filter the data for a specific time period. To do this, activate the 
Period selection toggle and choose the desired time range in the calendar. 

45 



Portable Rail Profilometer. PRP Series 

PRP [Revision 2.0.0] 15.03.2018 

 

 

 

 

To add a filter by Station or Line Number of the locomotive/wagon, select the 
desired value from the dropdown list. 

 

To remove the current filter, tap the Filter button ( ) and deactivate the toggle 

switch. 
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16.4. Viewing measurement results 

To view measurement results, tap on the desired entry. A list of measurements 
will open. 

 

In this mode, it is also possible to delete and export data. 

16.4.1. Saving a profile as a reference 

You can also save the profile of the selected rail as a reference. To do this, 
swipe the entry from right to left and tap Save. 
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Next, enter the reference profile name and tap  to save it. 
 

The saved reference profile can be viewed in the reference profile database 
(Advanced settings > Reference, see Reference profile). 

16.4.2. Viewing rail parameters 

To view the parameters and profile of the selected rail, tap on the corresponding 
entry. 

 

The window displays the identification data of the measured rail, the measured 
profile, and the calculated parameters. 
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There is an option to hide the reference profile display – simply uncheck the 

Reference profile option. 

16.4.3. Graphic representation of the rail profile 

The profile can be zoomed in by placing two fingers on the profile simultaneously 
and spreading them apart without lifting them from the screen. 

 

17. Data exchange between smartphone and PC 

To exchange data between the mobile device and the PC, select the device by 
navigating to File > Device > Mobile Device. 

 

17.1. Wi-Fi data transfer settings 

Wi-Fi is used for data transfer between the mobile device and the PC. 
To establish the connection, follow these steps: 
1. Select the synchronization type: Mobile device > Synchronization > WiFi. 
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2. Go to the server settings: Settings > DB, Server settings. 
 

For data transfer, the PC and the mobile device must be connected to the same 
Wi-Fi network. This can be a dedicated network created on the Android device (a virtual 
hotspot) or any home/office network. 

Prp_DB server port settings: 
Port (non-editable) – the port number used to connect the mobile device 

(default: 8090). 
 

Mobile device server settings: 
Port (non-editable) – the port number (default: 8091). 
IP address – the IP address of the mobile device on the network, used by the 

Prp_DB program to connect. 
The IP address must match the value specified in the mobile application 

settings. 
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Attention! 
To import into the Prp_DB database, the file must be in XML format (Railset.xml). 

 

 

17.2. Wireless data transfer 

When the Wi-Fi synchronization type is selected, the following data exchange 
options with the mobile device become available: 

• Transfer of the database file. 

• Transfer of the reference profile file. 

17.2.1. Transferring the database file to the PC 

During Wi-Fi synchronization, the measured data is exported from the PRP 
mobile application. 

17.2.2. Transferring the reference profile file 

To transfer a reference profile file from the PC to the PDA, follow these steps: 

• Select Mobile device > Reference file > Export. 
 

• Select the desired file with the .ref extension. 
If the transfer is successful, a confirmation message will appear: 

 

17.2.3. Importing the Railset.xml file 

If a wireless network is unavailable, the measured data can be exported to a file 
on the smartphone or sent via email. 

 

Next, copy the Railset.xml data file to the PC and import it into the Prp_DB 
database. 

– Select Synchronization > WiFi. 
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– Select Mobile device > Import Data, or click the Import Data button. 
 

– Select the Railset.xml data file. 
 

The measured profiles will be imported into the database. 

18. Installing software on PC 

18.1. Database support software installation 

The PRP_DB software is intended for maintaining the rail wear database on a 
personal computer. 

To install the software, insert a compact disk to PC CD drive, select and start 
Install_PRP.exe file in the Software folder. Follow instructions of the installation wizard. 
By default, the program is installed in C:\Program Files (x86)\Riftek, LLC\Prp_DB\. 
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18.2. Synchronization of mobile device and PC 

 

18.3. Launching the software 

To launch the program, select: 
Start > All programs > Riftek, LLC > PRP_DB > Prp_db.exe 
The main window appears as follows: 
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19. User settings of the program 

19.1. Parameter settings 

Select Settings > Parameters in the main window, or click . 
 

The Parameters window contains four tabs: 

• Rail parameters 

• Calculated parameters 

• L-parameters 

• Measurement method 

19.1.1. "Rail parameters" tab 

In this tab, you can select parameters, which will be displayed on the screen 
when browsing the database. 

 

If the parameter is selected, its value will be shown in the table of results and in 
the table of profiles. 
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19.1.2. "Calculated parameters" tab 

In this tab, you can select the geometrical parameters, which will be calculated 
and displayed on the screen when browsing the database. 

 

The description and functions of parameters see in par. 9.2. 

19.1.3. "L-parameters" tab 

In this tab, you can set the values of L-parameters. 
 

The description and functions of L-parameters see in par. 9.1. 

19.1.4. "Measurement method" tab 

In this tab, you can select the measurement method. 
 

The description and functions of measurement methods see in par. 12.1. 

19.1.4.1. Selection of measurement units 

All parameters and measurement results can be in the Metric system 
(millimeters), or in the English system (inches). 

To set the units of measurement, you need to select mm or inches in the Units 
of measurement field. After saving the changes, all information will be displayed in the 
selected units of measurement. 
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19.2. Database settings 

 
19.2.1. Setting the path to database 

It is possible for the user to change the drive and the directory of the profiles 
database storage. In the main window, select Settings > DB, Server settings. 

 

Next: 

• Click Ok. 

• Specify a new path to the database. 

• Confirm the creation of a new database. 
 

All database files will be copied to the specified path. 
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19.2.2. Creation of empty database 

To create an empty database, select File > New DB. 
 

All data except the reference files will be deleted from the database. At the 
same time, the DB(dd.mm.yy) directory will be created in the installation directory 
whereto all the deleted data will be copied (dd.mm.yy – current date). If necessary, 
these data can be restored. 

19.2.3. Import of database 

To import data to the database from the other database, you need to: 

• Select File > Import Data. 

• Select the directory with DB files in the left window. All files will appear in the 
right window: 

 

• Click OK to import data. 

57 



Portable Rail Profilometer. PRP Series 

PRP [Revision 2.0.0] 15.03.2018 

 

 

 
19.2.4. Language selection 

To change the language, select Settings > Language and select the required 
language support file. 

 

 

19.2.4.1. Preparation and installation of the language support file 

The user can change the language, form his own language support files as well 
as change/edit the terminology used. Language support files are located in the directory 
used in the process of installation. By default, the following directory is used: C: 
\Program Files (x86)\Riftek, LLC\Ikp5_db\Language\. 

The directory contains two files, RUS.lng and ENG.lng, to support Russian and 
English languages respectively. 

To create the support file for any other language, it is necessary to: 

• copy one of the existing files, for example - ENG.lng, under the other name, 
for example - DEU.lng; 

• edit the renamed file by using any text processor, namely, change all terms 
and phrases to analogous ones from the required language; 

• save the edited *.lng file in the Language directory. 
To edit the terminology, it is necessary to: 

• edit the corresponding language file by using any text processor; 

• save the edited *.lng file in the Language directory. 

19.3. Registration data 

 
19.3.1. Registration of organizations 

To add/chose the user organization, select Registration > Organization. 
Subsequently, this information will be used in automatic generation of reports. 
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Buttons: 

 
 

 
Add a new organization 

 

 
Delete the selected organization 

 

 
Edit the selected organization 

 

 
Exit the mode 

To select a current organization: 

• Click Edit. 

• Tick the depot. 

• Click Save. 
 

19.3.2. Registration of operators 

Steps to follow: Registration > Operator. Operators data are used for 
identifying operators by Number. 

 

Functions of buttons are similar to those in par. 19.3.1. 

19.3.3. Registration of reference profiles 

The program comes with several preset profiles. In addition, the user can form a 
description of the required profile himself or request it from RIFTEK (free service). 

To browse available profiles, select Registration > Reference: 
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The window of profiles displays the table with the list of reference profiles saved 
to database, and a graphical view of selected profile. 

Buttons: 
 

 

 
Delete the reference profile 

 

 
Import the reference profile from *.ref file 

 

 
Export the reference profile to *.ref file 

 

 
Exit the mode 

19.3.3.1. Request and registration of the profile file 

To get the .ref file of the reference profile, send the drawing of profile to RIFTEK 
(info@riftek.com). Register the received .ref file as follows: 

• Click Import. 

• In the window appeared indicate the way to the .ref file. 

• Click Open. 
The profile will be added to the base of reference profiles. 
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20. Working with profilograms and wear calculations 

20.1. Browsing the graph and profile coordinates 

To browse the saved profiles, select Database > Profiles, or click the Profiles 

button - . 
 

At the left side of the window you can see the Table of profiles tab, which 
contains a list of saved profiles. The table displays only those identification parameters 
that were selected in the parameters window (see par. 19.1). 

When selecting a profile, it is possible to browse a graphical image and 
geometric parameters of the measured rail. To browse the coordinates of the selected 
profile, you need to click the Profile Values button. After that, an additional tab will 
appear. 

Buttons: 
 

 

 
Show/hide the Profile Values tab 

 

 
Show/hide the Profile alignment tab 

 

 
Save the profile image to file (.bmp file) 

 

 
Print the profile image 

 

 
Change the background color of the graph 

 

 
Zoom in/out the profile graph 

 

 
Calculate geometric parameters 
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20.2. "Parameters" tab 

Calculated geometric parameters of the profile as well as L-parameters values 
are displayed on the Parameters tab, which is at the bottom of the window. 

 

 

20.2.1. Selecting a profile to compare 

There are two ways to compare: 

• with the reference profile, 

• with the measured profile. 
To compare the measured profile with the reference one, it is necessary to tick 

the Reference box. 
When comparing with the reference profile, select the required reference profile 

in the drop-down list. 
 

To compare two measured profiles, it is necessary to tick the Measured box. 
The Table of profiles tab will show an additional table for selecting a profile to compare. 

20.2.2. Selecting L-parameters values 

When calculating the geometric parameters, the specified support points are 
used. There are two variants of L-parameters: 

• General parameters 

• Profile parameters 
When selecting General parameters, values of L-parameters will be taken from 

the default parameters file (see par. 19.1.3). 
When selecting Profile parameters, values of L-parameters will be taken from 

the profile file, i.e. the values, which were set in PDA when measuring the rail. 
Values of L-parameters are displayed on the screen in the table of parameters. 

 

If necessary, it is possible to edit any value and to recalculate values of 
geometric parameters of the flange. To do it, click Calculate. Parameters of the 
measured profile and selected reference will be recalculated. 
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20.2.3. Geometric parameters of the profile 

The table of calculated geometric parameters displays only those parameters, 
which were selected in the parameters window (see par. 19.1.2). 

 

20.3. Wear calculation 

 
20.3.1. Fast wear calculation 

To obtain fast calculation of the profile wear at a certain point relative to the 
reference, put cursor bar to any of the profiles, and when a cross-like (+) mouse cursor 
appears press the left mouse key. The resulting screen will show the value of the 
coordinate difference between profiles taken along X- and Y-axes, as shown by arrows: 

 

To remove size indication from the screen, it is necessary to put cursor to any of 
the profiles and press the right mouse key. 

20.4. Browsing and saving a profile 

To browse the table of values, it is necessary to select Profile Values > Wear. 
The table will show deviations of the selected profile from the reference profile in two 
directions (X and Y). 
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20.4.1. Export to Excel, DXF, REF 

To export the table to the Exсel or DXF format or to create the reference file 
(REF), it is necessary to right-click on the table. The pop-up menu will appear: 

 

Select the needed menu item. 

20.5. Alignment of profiles 

To align the profiles relative to the reference profile, you need to click the 
Alignment button. The program will display an additional tab, where you can move the 
selected profile to the required position by using the arrows. 

 

Next, specify the translation step and move the profile by using the Up/Down, 
Left/Right buttons. 

 

To save the changed profile, go to the tab of identification parameters of the 
profile and click Save. 

 

To create a new profile, it is necessary to change the identification parameters of 
the profile. 

64 



Portable Rail Profilometer. PRP Series 

PRP [Revision 2.0.0] 15.03.2018 

 

 

65 

 
20.6. Superposition of profiles 

To superimpose several changed profiles, you need to tick the required profiles 
in the left table. Selected profiles will be displayed in different colors. 

 

20.7. Rescaling 

To change the image scale, mark a part of the image with the left mouse key, 
move the image by holding it with the right mouse key pressed, or with buttons Increase 

-  , Decrease -  and Show all - . 
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21. Viewing and editing data 

21.1. Viewing and filtering data 

Select Database > Table in the menu or click the Table button - . The form 
with results will be as follows: 

 

• Hide/show the field 
The table displays the identification and geometric parameters of the rail, which 
are selected for displaying in the parameters settings (see par. 19.1.1 and 
19.1.2). 

• Data sorting 
To sort data for any of the fields, click the left mouse key on the header of the 

field column: 
 

To cancel data sorting, press the Ctrl key and click the left mouse key on the 
header of the field column. 

• Data filtering 
In order to filter data in any of the fields, click the left mouse key on the header 

of the field grouping, and select the required value in the emerged drop-down list: 
 

To cancel filtering, all steps should be taken in the reverse order. 

• Data grouping 
To group data for any of the fields, click the left mouse key on the header of the 

field column, and, with the mouse key pressed, drag it onto the table header: 

66 



Portable Rail Profilometer. PRP Series 

PRP [Revision 2.0.0] 15.03.2018 

 

 

 

 

 

 

• Changing of the field position order 
To change the field position, click the left mouse key on the header of the field 

column and, with the mouse key pressed, drag it to the required position: 
 

Buttons: 
 

 

 
Add a profile 

 

 
Delete the selected profile 

 

 
Delete all profiles 

 

 
Edit the selected profile 

 

 
Export the profile coordinates to the Excel format 

 

 
Report preparation 

21.2. Editing data 

You can edit, add and delete data in/from the database. 

• Editing data 

To edit the current entry, click  and input/change the values of 
parameters. Click the Save button. 
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• Adding data 

To add a new data entry, click  and type the values of parameters. 
Click the Save button. 

• Deleting data 

To delete the current entry, click  and confirm the deletion. 
 

• Deleting all selected data 
If it is necessary to delete not only one entry but several entries combined by 

some condition, filter the data according to the corresponding attribute (see par. 22.1), 

click  and confirm the deletion. 
 

21.3. Report preparation 

When staying in the mode of scanning and editing data, the user can prepare 
reports in Excel, RTF, PDF formats, or print out reports. When preparing the report, the 
sorting used at the moment is taken into account. 

To generate a report, press the Report button. The program will offer to select 
the following options: 
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21.3.1. Excel-format report 

To prepare a report in Excel format, select Report in Excel and click ОК. 
 

21.3.2. Report for printout 

To prepare the report for printout, select Report for printout and click ОК. Data 
will be presented in the form of report ready for printout. 

 

The top toolbar contains the following buttons for operating with reports: 

• To printout the report, click . 

• To save in PDF format, click . 

• To save in Excel, RTF or PDF, click  and select the format you need: 
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22. Taking measurements under PC control (without 
PDA) 

The laser scanning module (RF570) can work under direct control of PC without 
PDA. To work under direct control of PC, it is necessary to select File > Device > 
Profilometer. 

 

In the main menu of the program, the PDA tab will be replaced with the 
Profilometer tab. 

 

The menu contains two available items: 

• Calibration 

• Measurement 
Before you start working with the profilometer, it is necessary to set the COM 

port for Bluetooth connection between the laser scanning module and PDA. The 
procedure is described in the User's manual that comes with the Bluetooth adapter. 
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Measurement 

 
22.1. Calibration 

To calibrate the device, select Profilometer > Calibration, or click . 
 

22.1.1. Bluetooth connection 

Select the COM port and click the Connect button. 
 

If the connection is successful, the device will be identified, and calibration 
parameters will be obtained. The status will be changed to Connected. 

 

The table of calibration parameters: 
 

Buttons: 
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The Auto calibration button will be active, if at least one measurement of the profile is 
performed and the reference profile is selected. 

Attention! Writing incorrect values of some parameters can lead to the incorrect work of the 
device. 

 
 

 
Reading calibration parameters 

 

 
Writing calibration parameters 

 

 
Automatic setting of calibration parameters 

 

22.1.2. Calibration of the profilometer 

• Place the profilometer on the calibration block. 

• Select the reference profile from the list (Compare > Reference). 

• Perform the measurement (the Measurement button) 

• Perform the calibration (the Autocalibr button). 

• Save calibration parameters (the Write param. button). 
 

Calibration parameters can be set manually. To do it, click the left mouse key on 
the field of the required parameter value, and enter the new one. 

 

Buttons functions, work with profiles and calculation of required parameters are 
described in par. 20. 
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22.2. Measurement by using PC 

Select Profilometer > Measurement, or click . 
 

When the Bluetooth connection is established (see par. 22.1.1), the 
Measurement button is active. 

22.2.1. Saving data 

• Place the profilometer on the rail. 

• Perform the measurement (the Measurement button). 

• Enter the identification parameters of the rail. 
 

• To save results, click Save. 

• The measured profile will be saved to the database. 
Button functions, work with profiles and calculation of required parameters are 

described in par. 20. 
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Attention! Please follow the sequence of these points. 

23. Annex 1. Charging procedure 

• Switch off the PDA (laser module). 

• Connect the charging device to PDA (laser module). 

• Connect the charging device to 220V AC. 

• Time of charging: PDA - 4 hours, laser module - 5 hours. Full-charge 
indication: PDA - blue LED is lit; laser module - green LED is lit. 

• Disconnect the charging device from 220V AC. 

• Disconnect the charging device from PDA (laser module). 
 

24. Annex 2. Testing and calibration 

We can supply the profilometer complete with the RF570.20.100 calibration-rail 
simulation unit (Fig. 1A) and the RF570Calibr calibration program, which are designed 
for periodic testing and calibration of the profilometer. 

Instead of the calibration unit, use can be made of the rail with known profile 
entered to the database. 

Before start the testing and calibration process, it is necessary to set the COM 
port for Bluetooth connection between the laser scanning module and PDA. The 
procedure is described in the user manual that comes with the Bluetooth adapter. 

24.1. Preparation for testing/calibration 

• Install the RF570Calibr program on the PC. 

• Install Bluetooth-connection between the scanning module and PC. 

• Place the profilometer on the calibration unit. 

• Start the RF570Calibr program. 
 

• To establish the Bluetooth connection, select the required port. 
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The device will be identified, and calibration parameters will be read. 
 

To perform the measurement: 

• Go to the Profile tab. 

• Select the reference profile: tick Compare and select the required reference 
profile from a drop-down list. 

• Click the Measurement button. 
 

24.2. Calibration 

To carry out the automatic calibration, follow the steps below: 

• Select the reference profile from the list. 

• Perform the measurement (the Measurement button). 

• Perform the calibration (the Autocalibr button). 

• Go to the Parameters tab and save parameters (the Write parameters 
button). 
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If, for some reason, the parameters have incorrect values (negative or zero), you 
must restore the factory settings by pressing the Load default button. After that, 
recalibrate the profilometer. 

 

 

 
25. Warranty policy 

Figure 1A 

Warranty assurance for the Portable Rail Profilometer PRP Series – 24 months 
from the date of putting in operation; warranty shelf-life – 12 months. 

26. Revisions 
 

Date Revision Description 

30.05.2012 1.0.0 Starting document. 

15.03.2018 2.0.0 Updated the PRP description and the software description. 
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27. Distributors 
 

AUSTRALIA 

Applied Measurement 
Australia Pty Ltd 
RAILWAY INSTRUMENTS ONLY 
Thornton Plaza, Unit 5, 
27 Thornton Crescent, Mitcham 
VIC 3132, Australia 
Tel: +61 39874 5777 
Fax: +61 39874 5888 
sales@appliedmeasurement.com.au 
www.appliedmeasurement.com.au 

BELGIUM 

Althen Sensors & Controls 
BV 
Verrijn Stuartlaan 40, 2288 EL, 
Rijswijk, Leidschendam 
The Netherlands 
Tel: +31 0 70 392 4421 
Tel: +31 0 61 396 7830 
Tel: +31 0 64 323 8393 
sales@althen.nl 
info@althen.nl 
www.althensensors.com 

BOSNIA AND 
HERZEGOVINA 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

 

BRAZIL 

CAPI Controle 
e Automação Ltda 
Rua Itororó, 121, CEP 13466-240 
Americana-SP, Brazil 
Tel: +55 19 36047068 
Fax: +55 19 34681791 
capi@capicontrole.com.br 
www.capicontrole.com.br 

BULGARIA 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

CHILE 

MOL INGENIERIA LTDA 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
República de Honduras 11936 
Las Condes, Santiago de Chile 
Tel: +56 9 59200362 
hconcha@molingenieria.com 
www.molingenieria.com 

 

CHILE 

Verne SpA 
Apoquindo 2818, oficina 31 
Las Condes, Santiago, Chile 
Tel: +56 2 228858633 
info@verne.cl 
jsaavedra@verne.cl 
www.verne.cl 

CHINA 

Beijing Haiwei Lutong 
Technology Co., Ltd 
Yard 1, Tianxing Street, Fangshan 
District, Beijing, China 
Tel: +86 10 8366 1866 
Fax: +86 10 8366 1866 
info@haiwlt.com 
www.haiwlt.com 

CHINA 

Chongqing Wolf Industrial 
Technology Co., Ltd 
Room 2307 / 2308, Light of City 
international business building, 
No. 19 Jiangnan Avenue, Nan'an 
District, Chongqing, China 
Tel: 023 62832618 
Fax: 023 62832113 
info@wolf-hk.com 
www.wolf-hk.com 

 

CHINA 

Beijing Gemston Mechanical 
& Electrical Equipment Co., 
Ltd 
RAILWAY INSTRUMENTS ONLY 
Room 613, Anfu Mansion, Fengtai 
District, Beijing, China 
Tel: +86 10 6765 0516 
Fax: +86 10 6765 6966 
Mobile: +86 137 1755 1423 
dh0526@163.com 
www.baoft.cn 

CHINA 

Xi'an Win-Success 
Automation Technology 
Co.,Ltd 
Room 3-1-1039, Iduhui Building, 
No.11 Tangyan South Road 
High-Tech Zone, Xi’an 
Shaanxi PRC, China 
Tel: +86 29 81106280 
Fax: +86 29 81106285 
Mob: +86 133 19271405 
info@maxsenor.com 
www.maxsensor.com 

CHINA 

Micron-Metrology co., Ltd 
No.2, Kecheng Rd., Industrial Park 
District, Suzhou, 
Jiangsu Province., China 
Tel: 0512 65589760 
Mob: +86 189 1806 9807 
sales@micron-metrology.cn 
www.micron-metrology.cn 
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CHINA 

Zhenshangyou Technologies 
Co., Ltd 
Rm 2205-2210, Zhongyou Hotel 
1110 Nanshan Road, Nanshan 
District 518054 Shenzhen, China 
Tel: +86 755-26528100/8011/8012 
Fax: +86 755-26528210/26435640 
info@51sensors.com 
www.51sensors.com 

CROATIA 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

CZECH REPUBLIC 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

 

DENMARK 

BLConsult 
Ryssbält 294 
95 291 Kalix, Sweden 
Tel: +46 70 663 19 25 
info@blconsult.se 
www.blconsult.se 

ESTONIA 

FoodLab OÜ 
Haabersti linnaosa, Astangu tn 52 
13519 Eesti, Tallinn, Estonia 
Tel: +372 56 363110 
foodlab.ee@gmail.com 

FINLAND 

Kvalitest Industrial AB 
EXCEPT FOR RAILWAY 

INSTRUMENTS 
Ekbacksvägen 28, 
16869 Bromma, Sweden 
Tel: +46 0 76 525 5000 
sales@kvalitest.com 
www.kvalitest.com 
www.kvalitest.se 

 

FINLAND 

TERÄSPYÖRÄ-STEELWHEEL 
OY 
RAILWAY INSTRUMENTS ONLY 
Juvan teollisuuskatu 28 
FI-02920 ESPOO, Finland 
Tel: +358 400 422 900 
Fax: +358 9 2511 5510 
steelwheel@steelwheel.fi 
www.teraspyora.fi 

FRANCE 

BLET Measurement Group 
S.A.S. 
1 avenue du Président Georges 
Pompidou, 92500 Rueil 
Malmaison, France 
Tel: + 33 0 1 80 88 57 85 
Fax: +33 0 1 80 88 57 93 
technique@blet-mesure.fr 
www.blet-mesure.fr 

GERMANY 

Disynet GmbH 
Breyeller Str. 2, 41379 
Brueggen, Germany 
Tel: +49 2157 8799 0 
Fax: +49 2157 8799 22 
disynet@sensoren.de 
www.sensoren.de 

 

GERMANY 

Finger GmbH & Co. KG 
OPTICAL MICROMETERS ONLY 

Sapelloh 172, 31606 
Warmsen, Germany 
Tel: +49 5767 96020 
Fax: +49 5767 93004 
finger@finger-kg.de 
www.finger-kg.de 

GERMANY 

ALTHEN GmbH Meß- und 
Sensortechnik 
Dieselstrasse 2, 65779 
Kelkheim, Germany 
Tel: +49 0 6195 7 00 60 
info@althen.de 
www.althensensors.com/de/ 

HUNGARY 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

 

INDIA 

Influx Big Data Solutions Pvt 
Ltd 
No:2, Krishvi, Ground Floor, 
Old Airport Road, Domlur, 
Bangalore - 560071, India 
Tel: +91 73 37748490 
Tel: +91 94 48492380 
milan@influxtechnology.com 
support_india@influxtechnology.com 
www.influxtechnology.com 

INDIA 

Paragon Instrumentation 
Engineers Pvt. Ltd. 
RAILWAY INSTRUMENTS ONLY 
200, Station Road, 
Roorkee, 247 667, India 
Tel: +91 1332 272394 
tanuj@paragoninstruments.com 
www.paragoninstruments.com 

INDONESIA 

PT. DHAYA BASWARA 
SANIYASA 
Botanic Junction Blok H-9 NO. 7 
Mega Kebon Jeruk, Joglo 
Jakarta,11640, Indonesia 
Tel: +62 21 2932 5859 
management@ptdbs.co.id 
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ISRAEL 

Nisso Dekalo Import 
Export LTD 
1 David Hamelech Street 
Herzlia 46661 Israel 
Tel: +972 99577888 
Fax: +972 99568860 
nissodekaloltd@outlook.com 
www.fly-supply.net 
www.aircraft-partsupply.com 

ITALY 

FAE s.r.l. 
Via Tertulliano, 41 
20137 Milano, Italy 
Tel: +39 02 55187133 
Fax: +39 02 55187399 
fae@fae.it 
www.fae.it 

JAPAN 

Tokyo Instruments, Inc. 
6-18-14 Nishikasai, Edogawa-ku, 
Tokyo, 134-0088 Japan 
Tel: +81 3 3686 4711 
Fax: +81 3 3686 0831 
f_kuribayashi@tokyoinst.co.jp 
www.tokyoinst.co.jp 

 

LATVIA 

FoodLab OÜ 
Haabersti linnaosa, Astangu tn 52 
13519 Eesti, Tallinn, Estonia 
Tel: +372 56363110 
foodlab.ee@gmail.com 

LUXEMBOURG 

Althen Sensors & Controls 
BV 
Verrijn Stuartlaan 40, 2288 EL, 
Rijswijk, Leidschendam 
The Netherlands 
Tel: +31 0 70 392 4421 
Tel: +31 0 61 396 7830 
Tel: +31 0 64 323 8393 
sales@althen.nl 
info@althen.nl 
www.althensensors.com 

MALAYSIA 

OptoCom InstruVentures 
H-49-2, Jalan 5, Cosmoplex 
Industrial Park, Bandar Baru 
Salak Tinggi, Sepang, Malaysia 
Tel: 603 8706 6806 
Fax: 603 8706 6809 
optocom@tm.net.my 
www.optocom.com.my 

 

MONTENEGRO 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

NETHERLANDS 

Althen Sensors & Controls 
BV 
Verrijn Stuartlaan 40, 2288 EL, 
Rijswijk, Leidschendam 
The Netherlands 
Tel: +31 0 70 392 4421 
Tel: +31 0 61 396 7830 
Tel: +31 0 64 323 8393 
sales@althen.nl 
info@althen.nl 
www.althensensors.com 

NORWAY 

BLConsult 
Ryssbält 294, 
95 291 Kalix, Sweden 
Tel: +46 70 663 19 25 

info@blconsult.se 
www.blconsult.se 

 

NORWAY 

Salitec AS 
PB 468, N-1327 
Lysaker, Norway 
Tel: +47 23 891015 
Fax: +47 92101005 
mail@salitec.no 
www.salitec.no 

PERU 

Verne Perú S.A.C. 
Las Codornices 104, 
Surquillo, Lima, Peru 
Tel/fax: +51 992436734 
info@verne.cl 
www.verne.cl 

POLAND 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

 

POLAND 

RIFTEK EUROPE sp. z o.o. 
ul. Domaniewska 17/19, 02-672 
Warsaw, Poland 
info@riftek.com 
www.riftek.com 

PORTUGAL 

Campal Inovacoes 
Ferroviarias Lda. 
Lagoas Park, Edifício 7, 1° Piso 
Sul, 2740-244 Porto Salvo, Oeiras, 
Portugal 
Tel: +351 21 584 4348 
campal@campal.pt 
www.campal.pt 

SERBIA 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 
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SLOVAKIA 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

SLOVENIA 

ASCO RAIL sp. z o.o. 
EXCLUSIVE REPRESENTATIVE 

FOR RAILWAY EQUIPMENT 
ul. Wielowiejska 53, 44-120 
Pyskowice, Poland 
Tel: +48 32 230 45 70 
Fax: + 48 32 233 21 34 
biuro@ascorail.pl 
export@ascorail.pl 
www.ascorail.pl 

SOUTH KOREA 

BS Holdings 
B-201,Wonpogongwon 1ro, 
59 Danwon-gu, Ansan-si, 
Gyeonggi-do 15455, Republic of 
Korea 
Tel: +82 31 411 5011 
Fax: +82 31 411 5015 
bsh5011@hanmail.net 
www.lasersolution.co.kr 

 

SOUTH KOREA 

PROSEN. CO., LTD 
M-1001, Songdo techno park IT 
center, 32, Songdogwahak-ro, 
Yeonsu-gu, Incheon, 21984, 
Republic of Korea 
Tel: +82 32 811 3457 
Fax: +82 32 232 7458 
trade@prosen.co.kr 
www.prosen.co.kr 

SPAIN 

IBERFLUID Instruments S.A. 
C/ Botanica, 122, 08908 
L'Hospitalet de Llobregat 
Barcelona 
Tel: +34 93 447 10 65 
Fax: +34 93 334 05 24 
myct@iberfluid.com 
www.iberfluid.com 

SWEDEN 

BLConsult 
Ryssbält 294, 
95 291 Kalix, Sweden 
Tel: +46 70 663 19 25 

info@blconsult.se 
www.blconsult.se 

 

SWEDEN 

Kvalitest Industrial AB 
EXCEPT FOR RAILWAY 

INSTRUMENTS 
Ekbacksvägen 28, 
16869 Bromma, Sweden 
Tel: +46 0 76 525 5000 
sales@kvalitest.com 
www.kvalitest.com 
www.kvalitest.se 

SWITZERLAND 

ID&T GmbH 
Gewerbestrasse 12/a 
8132 Egg (Zurich), Switzerland 
Tel: + 41 44 994 92 32 
Fax: + 41 44 994 92 34 
info@idtlaser.com 
www.idtlaser.com 

THAILAND 

Advantech Solution Co., Ltd. 
20/170 Motorway Rd., 
Kwang Pravet, Khet Pravet, 
Bangkok, Thailand 10250 
Tel: +662 1848705 
Fax: +662 1848708 
sales@advantechsolution.com 
www.advantechsolution.com 

 

TURKEY 

MAK Elektronik Malzeme 
Analiz ve Kalite Kontrol 
Cihazlari Dis Tic. Ltd. Sti. 
Cenap Sahabettin Sokak, No:39, 
34718 Kosuyolu - Kadikoy / 
Istanbul - TURKEY 
Tel: +90 216 402 10 34 
Fax: +90 216 402 10 35 
ulastac@metalografi.net 
www.makelektronik.com.tr 

TURKEY 

TEKMA Mühendislik A.S. 
Cevizli Mh. M. Kemal Cd., 
Hukukçular Towers, 
A-Blok, No: 66-A/39 
Kartal - Istanbul 
Tel: +90 216 970 1318 
Tel: +90 850 840 2334 
info@tekma.eu 
www.tekma.eu 

UKRAINE 

KODA 
Frunze st. 22, 61002, 
Harkov, Ukraine 
Tel/Fax: +38 057 714 26 54 
mail@koda.com.ua 
www.koda.com.ua 

 

UNITED KINGDOM, 
IRELAND 

Althen UK 
Northamptonshire 
United Kingdom 
Tel: +44 0 7823 921427 
t.stoyles@althen.co.uk 
www.althensensors.com 
www.althencontrols.com 

USA 

Althen Sensors & Controls 
2531 Bradley St., Oceanside, CA, 
92056, USA 
Tel: 858 633 3572 
r.ream@althensensors.com 

USA, CANADA, MEXICO 

Acuity Products of Schmitt 
Industries, Inc. 
2765 NW Nicolai Street 
Portland, OR, 97210, USA 
Tel: +1 503 227 7908 
Fax: +1 503 223 1258 
sales@acuitylaser.com 
www.acuitylaser.com 
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28. RIFTEK’s measurement instruments for railway 
transport 

 
Railway wheel profile gauge, IKP Series 

Laser Profilometer IKP-5 Series is employed for: 

• Measuring geometrical parameters of the wheel 
flange (thickness, slope, height), rim/tire thickness. 

• Taking full profile of the wheel rolling surface. 

• Maintaining the wear database. 

• Tolerance control and sorting when checking, 
inspecting, repairing and forming railway wheelsets. 

Measurements are made directly on the rolling stock 
without rolling out the wheelset. 

 
 

 
Rail profile measurement gauge, PRP Series 

The main functions of PRP are as follows: 

• Obtaining information on the cross-section profile of 
the railhead acting face. 

• Full profile scanning and analysis of the railhead 
acting face. 

• Visualization of combined graphic images of the 
actual and new cross-section profiles of the railhead. 

 
 
 
 

 
Wheel diameter measuring gauge, IDK Series 

Electronic gauge is designed to measure the wheel rolling 
circle diameter of railway, metro and tram wheelsets. 
Measurements are made directly on the rolling stock 
without rolling out the wheelset. 
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Back-to-back distance measuring gauge, IMR Series 

Electronic gauge is designed to measure the back-to-back 
distance of railway, metro and tram wheels in the course of 
checkup, examination, repair and formation of wheelsets. 
Measurements are made directly on the rolling stock 
without rolling out the wheelset. 

 
 
 
 
 
 

Back-to-back distance measuring gauge, IMR-L Series 

Electronic gauge is designed to measure the back-to-back 
distance of railway, metro and tram wheels in the course of 
checkup, examination, repair and formation of wheelsets. 
Measurements are made directly on the rolling stock 
without rolling out the wheelset. 

 
 
 
 

Disc brakes profile gauge, IKD Series 

Electronic gauge is employed for laser scanning and 
measurement of disc brakes wear parameters. 
The main functions of IKD are as follows: 

• Obtaining information on the profile of the disc 
brakes acting face. 

• Full profile scanning and analysis of the disc brakes 
acting face. 

• Visualization of combined graphic images of the 
actual and new disc brakes profiles. 

 

 
Real-time wheels geometry measurement system 
3DWheel 

The system is designed for non-contact automatic 
measurement of geometrical parameters of railway wheels 
and uses a combination of 2D laser scanners mounted 
wayside in the track area. 
The system can be easily installed on any type of railway 
infrastructure. 
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